TLS 1.2 and older operating systems and outlook

In recent years, older versions of the security protocol TLS have become insecure and are being phased out. This means that anything under TLS 1.2 is not very secure anymore. EthicalHost will be phasing out support on email connections using anything less than TLS 1.2 and this means you mail may stop working if you use older versions of Apple OS (older than OS X Mavericks - 10.10.4) or MS Outlook such as outlook 2007 or earlier.

Outlook 2007 and earlier and Windows 7

There is a workaround for Outlook 2007 and here is what you need to do:

1) First you need to download this KB article:  KB3140215

2) After that is updated, please read through the KB article page about as it talks about making registry changes. Don't do it manually, use the EASY fix solution.

>>Note The hotfix installer doesn't add the DefaultSecureProtocols value. The administrator must manually add the entry after determining the override protocols. Or, you can install the "Easy fix" to add the entry automatically.

so click the blue download link and run that program.

If this still doesn't solve your problem and you are on Windows 7, please see this help article and video as well:

Cpanel TLS 1.2 Documentation

 

https://www.screencast.com/t/J04URLIC6Qg (requires adobe flash) please note to use powershellx86 as shown a bit later in the video)

if you still have issues, we can help! contact us and we can arrange to do a remote session to help do this for you.

For Older versions of Mac OS

a) If you can not update your OS, you only option is to use an alternate email program like Mozilla Thunderbird  instead. I know you may not want to move your mail to a new client, but sometimes it’s easier, faster and less expensive in the long run. Download and install Mozilla Thunderbird here.

b) You can attempt to update your operating system

Update the operating system to OS X Sierra, or 10.12. High Sierra seems to have the best support, though, which is 10.13. Older versions of OS X prevent Apple Mail from working correctly with newer versions of security protocols.
Many people have had this problem, and the general consensus of the majority was to update to Sierra or later.

Updating OS X is relatively simple.

  • outlook 2007, tls, tls1.2
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

Secure POP3, SMTP and IMAP

You can use secure connections for POP3, IMAP and SMTP connections. To do so, follow these...

How do I create email accounts?

To create an email account login to your control panel and under the 'Mail' Section click...

What are the POP3 and SMTP server settings?

For your incoming (POP3) server, please use  mail.ethicahost.ca For the outgoing (SMTP)...

Can I check my emails when travelling?

Yes, you can check your emails using a webmail interface at...

How can I setup a link to go directly to webmail?

If you want to create a link using your domain to take you directly into your...